Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Errors, malfunctions, website typos.
Post Reply
zaxus
F4 - Digitalis
Posts: 4
Joined: Tue Dec 01, 2015 7:10 pm

Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by zaxus » Tue Dec 01, 2015 7:16 pm

Compiled Giada from source today and after much wrangling with deps, managed to get it to build. Now I can start the binary from the command line, but I receive the following errors:

[GUI] Alert: Your soundcard isn't configured correctly. Check the configuration and restart Giada.

I can close that dialog, but when I hit the "Config" tab, Giada crashes with a SegFault. It had been complaining about a bad conf file, but it appears to have written a proper one this last time.

I would be happy to provide any info you need to help me get this running. Giada looks like the missing link to my Linux audio production needs!

Thanks!

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by FFT » Tue Dec 01, 2015 7:42 pm

Hello zaxus,

First of all thanks for your feedback! It would be great if you could paste here the console messages. You can enable the debug output from "Config" -> "misc" tab -> "debug to standard output".

zaxus
F4 - Digitalis
Posts: 4
Joined: Tue Dec 01, 2015 7:10 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by zaxus » Tue Dec 01, 2015 10:27 pm

Is it possible to set that in the conf file? When I click on Config Giada crashes...

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by FFT » Wed Dec 02, 2015 8:29 am

Ops sorry, I don't know why I thought it crashed only on "Sound System" tab, my bad. So in the config file set "logMode" to 1, aka #define LOG_MODE_STDOUT 0x01

zaxus
F4 - Digitalis
Posts: 4
Joined: Tue Dec 01, 2015 7:10 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by zaxus » Wed Dec 02, 2015 10:48 am

No problem! Here's the output with logmode set to 1:

Code: Select all

[init] Giada 0.10.2 - Wed Dec  2 04:46:20 2015
[init] configuration file ready
[MidiMapConf::init] scanning midimaps directory...
[MidiMapConf::init] unable to scan midimaps directory!
[MidiMapConf::readFromFile] midimap not specified, nothing to do
[KA] using system 0x2
[KM] using system 0x0
[KM] 1 output MIDI ports found
  0) Midi Through 14:0
[KM] 1 input MIDI ports found
  0) Midi Through 14:0
[gKeyboard::__cb_addColumn] new column added (index = 0), total count=1, addColumn(x)=384
[gKeyboard::__cb_addColumn] new column added (index = 1), total count=2, addColumn(x)=760
[gKeyboard::__cb_addColumn] new column added (index = 2), total count=3, addColumn(x)=1136
[gKeyboard::__cb_addColumn] new column added (index = 3), total count=4, addColumn(x)=1512
[gKeyboard::__cb_addColumn] new column added (index = 4), total count=5, addColumn(x)=1888
[gKeyboard::__cb_addColumn] new column added (index = 5), total count=6, addColumn(x)=2264
Segmentation fault (core dumped)

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by FFT » Wed Dec 02, 2015 9:30 pm

Thanks! That part

Code: Select all

[...]
[KA] using system 0x2
[KM] using system 0x0
[...]
looks a bit strange to me. It seems that Giada didn't find any soundcard available. I would ask you another little test with the config file: change the soundSystem key into

Code: Select all

soundSystem=0
or

Code: Select all

soundSystem=1
.

Thanks!

zaxus
F4 - Digitalis
Posts: 4
Joined: Tue Dec 01, 2015 7:10 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by zaxus » Thu Dec 03, 2015 10:56 am

Thanks for your help so far!

Neither of those worked, but when I did the sound test from the Ubuntu Sound Settings, I got no sound, so I tried a reboot.

Post-reboot, I retested my sound and it was working. I was able to launch Giada and get into the Config tab, where it complained that Jack wasn't running (because it wasn't), so I shut down Giada and started Jack. I was able to launch Giada and again get into Config, which listed Jack as my soundcard. However, after I shut Giada down and started it one more time, it went back to the same issue. I tested my sound again, and it was not working.

It appears that Jack might be crashing my sound system. :-/

I know that's not a Giada issue, but any hints?

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Giada 0.10.2 Crashes on Config Tab on Ubuntu 14.04

Post by FFT » Sat Dec 05, 2015 10:06 am

Unfortunately we have little control over Jack and also honestly I don't know what's going on in your OS. Could you try with another JACK-based app and see what happens?

Post Reply