Page 1 of 1

No "device does not send note off" with ver 15.2

Posted: Mon Sep 17, 2018 6:03 pm
by djMo
Ive noticed that there is no "device does not send note off" option in the midi configuration setup in version 15.2 and I'm not sure if it's related or not, but now the global midi options seem to not operate as they should, for example, when I learn a midi button for "play/stop", the option only works when I hold the button in with my midi device but does not toggle it as it did with version 15.1. This is quite a big deal when trying to use the looper live. for the mean time, 15.1 is a better option....

Re: No "device does not send note off" with ver 15.2

Posted: Sat Sep 22, 2018 10:38 am
by FFT
Yes, the "device does not send note off" option was removed. Now Giada should be smart enough to handle those devices automatically. I'm not so sure I understand the problem: is now impossible for you to learn the keypress/keyrelease actions?

Re: No "device does not send note off" with ver 15.2

Posted: Fri Oct 12, 2018 5:42 pm
by djMo
the learning works fine, but the action doesn't work as a toggle. for example, I have to hold the button in if I want it to work. but this is only for the global midi inputs such as play/stop, metronome, etc. all other channel midi inputs work as normal.

Re: No "device does not send note off" with ver 15.2

Posted: Sun Oct 14, 2018 11:53 am
by FFT
Tested here with a couple of MIDI devices, both with "correct" and "dumb" note off messages. I wasn't able to reproduce the bug. I have assigned a key to the play/stop transport, no need to hold the button.

I would like to inspect what kind of MIDI message your device is sending: could you paste here the debug output? Here's a quick tutorial on how to enable debug messages. Thanks!