[FIXED] Latest Giada does not launch

Errors, malfunctions, website typos.
lverona
F9 - Lavender
Posts: 43
Joined: Tue Apr 17, 2012 7:45 am

[FIXED] Latest Giada does not launch

Post by lverona » Thu Jul 19, 2012 10:50 am

I am still on Ubuntu 10.04

Installed from new deb.
Here's the error:

louigi@louigi-laptop:~$ giada_lin
giada_lin: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by giada_lin)

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Latest Giada does not launch

Post by FFT » Mon Jul 23, 2012 12:22 pm

aahhh, finally we came across the glibc hell :)
That's because we are compiling Giada on Ubuntu 12.04. I will upload a temporary deb very soon, in order to test a couple of solutions.

lverona
F9 - Lavender
Posts: 43
Joined: Tue Apr 17, 2012 7:45 am

Re: Latest Giada does not launch

Post by lverona » Mon Jul 23, 2012 8:30 pm

Thank you and sorry that I ask for support of an older Ubuntu, but everything works so well, I am very reluctant to install something new while it does )

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Latest Giada does not launch

Post by FFT » Thu Jul 26, 2012 8:51 am

lverona wrote:Thank you and sorry that I ask for support of an older Ubuntu, but everything works so well, I am very reluctant to install something new while it does )
Don't worry, a minimum of backward compatibility is always handy.

The following is a .deb of the 0.5.0 version compiled on Ubuntu 10.04:
http://dl.dropbox.com/u/21109122/giada_ ... lin.tar.gz

This is the same 0.5.0 compiled on Ubuntu 12.04 with the -static-libstdc++ flag (not a good idea, just for testing):
http://dl.dropbox.com/u/21109122/giada_ ... lin.tar.gz

let me know what happens :)

lverona
F9 - Lavender
Posts: 43
Joined: Tue Apr 17, 2012 7:45 am

Re: Latest Giada does not launch

Post by lverona » Fri Jul 27, 2012 9:08 pm

First one worked, thanks!
Should I try the second one as well?

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: Latest Giada does not launch

Post by FFT » Wed Aug 01, 2012 10:46 pm

Well, that's just a small test for the compiler flag. Since the first option worked well, you can safely forget the other one.

lverona
F9 - Lavender
Posts: 43
Joined: Tue Apr 17, 2012 7:45 am

Re: [FIXED] Latest Giada does not launch

Post by lverona » Sun Nov 18, 2012 7:28 pm

Guys, I have Error: Dependency is not satisfiable: libsndfile

I am still on Lucid (yikes!)
Is it possible to do smth for me? =)))

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: [FIXED] Latest Giada does not launch

Post by FFT » Thu Nov 22, 2012 12:42 pm

lverona wrote:Guys, I have Error: Dependency is not satisfiable: libsndfile

I am still on Lucid (yikes!)
Is it possible to do smth for me? =)))
I think you have an old version of libsndfile. What does

Code: Select all

dpkg -l *libsndfile*
say?

(sorry for the delay, we are packaging the 0.5.4 with lots of new issues for you :mrgreen: )

lverona
F9 - Lavender
Posts: 43
Joined: Tue Apr 17, 2012 7:45 am

Re: [FIXED] Latest Giada does not launch

Post by lverona » Fri Nov 30, 2012 3:36 pm

louigi@louigi-laptop:~$ dpkg -l *libsndfile*
dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 42440 package 'phasex-dev':
error in Version string 'm1-1lucid0~autostatic0': version number does not start with digit
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
un libsndfile-dev <none> (no description available)
un libsndfile0-de <none> (no description available)
ii libsndfile1 1.0.21-2ubuntu Library for reading/writing audio files
ii libsndfile1-de 1.0.21-2ubuntu Development files for libsndfile; a library
un libsox-fmt-lib <none> (no description available)

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: [FIXED] Latest Giada does not launch

Post by FFT » Fri Nov 30, 2012 5:03 pm

lverona wrote: ii libsndfile1 1.0.21-2ubuntu Library for reading/writing audio files
ii libsndfile1-de 1.0.21-2ubuntu Development files for libsndfile; a library
It's definitely the 1.0.21 version, the same we use when compiling the binaries.
Maybe it is a bug of the .deb package: if you feel brave, try these steps:
  • open the .deb with the archive manager
  • edit [package.deb]/DEBIAN/control with a text editor
  • change

    Code: Select all

    Depends: libjack0, libsndfile
    into

    Code: Select all

    Depends: libjack0, libsndfile1
    (see the missing "1"?)
  • save, close and relaunch.

Post Reply