compile error

Post Reply
bitwo
F3 - Chamomille
Posts: 2
Joined: Sun Jun 19, 2016 8:06 pm

compile error

Post by bitwo » Sun Jun 19, 2016 8:18 pm

I am on
Version Linux Mint 17.3 Rosa 64-bit
Kernel Linux 3.19.0-32-generic x86_64
and with
./configure --target=linux
I get the message
...
checking for unistd.h... yes
checking FL/Fl.H usability... no
checking FL/Fl.H presence... no
checking for FL/Fl.H... no
configure: error: library 'fltk' not found!

apt-get does not find fltk ...

What's now?

bitwo
F3 - Chamomille
Posts: 2
Joined: Sun Jun 19, 2016 8:06 pm

Re: compile error

Post by bitwo » Tue Jun 21, 2016 1:07 pm

Found FLTK. Installed giada successfully.

JonNCGiles
F4 - Digitalis
Posts: 3
Joined: Mon Sep 05, 2016 1:40 am

Re: compile error

Post by JonNCGiles » Mon Sep 05, 2016 1:47 am

Hello and thanks for making this great application. I am trying to use it on a raspberry pi, and although I can install it from the repository, I can't seem to get the plugins support that I can get on the osx version. When the gui comes up, there isn't a button to add a plugin at all, and it does not show up on the preferences.

I know there are some issues of using VST code, so I thought I would try compiling but I am getting this:

./src/deps/juce/juce_core/maths/juce_MathsFunctions.h:112:109: error: assuming signed overflow does not occur when assuming that (X - c) > X is always false [-Werror=strict-overflow]
Type jmin (const Type a, const Type b) { return (b < a) ? b : a; }
^
cc1plus: all warnings being treated as errors
Makefile:2262: recipe for target 'src/deps/juce/juce_gui_basics/giada-juce_gui_basics.o' failed
make: *** [src/deps/juce/juce_gui_basics/giada-juce_gui_basics.o] Error 1

I don't need to compile it, but I do need to have plugin support. Could someone help? Thanks! Jon

JonNCGiles
F4 - Digitalis
Posts: 3
Joined: Mon Sep 05, 2016 1:40 am

Re: compile error

Post by JonNCGiles » Wed Sep 07, 2016 3:27 pm

Hello again:

I was able to finally compile giada, after a friend helped me with editing the Makefile that had options I did not need like: treat all warnings as errors!

I am running it now on the pi, but for some strange reason when I try to load a sample I can't load anything off the flash drive. I even tried a drag and drop and it did not work.

I tested to see if there was something wrong with my pi, and ran the pre-compiled package you can get from the raspbian repos, and I was able to load samples no problem. I checked permissions on the version I compiled, as well as the sound files and they seem correct.

Does anyone have an idea what might be wrong with my compile? It must be that.

Thanks

jg

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: compile error

Post by FFT » Thu Sep 08, 2016 8:56 pm

Hi JonNCGiles,

You are right, those warnings come from JUCE, the library used for VST management. Buried in the Makefile lies an esoteric instruction:
JUCE makes GCC complain if compiled with optimization set to -O2.
Call configure script as follows:

./configure CXXFLAGS='-g -O1 -pedantic' --target=linux --enable-vst
You can either disable warnings or compile Giada with a lower optimization level.

For what concerns your issue on sample loading: please paste here any console output (remember to enable logging: Config -> Misc -> Debug messages) so I/we can take a closer look. Thanks!

User avatar
Duchamp
Site Admin
Posts: 39
Joined: Thu Mar 08, 2012 6:42 pm

Re: compile error

Post by Duchamp » Thu Sep 08, 2016 8:58 pm

@FFT I think we should add those information to our official documentation pages and GitHub Wiki. I'll do it soon.

JonNCGiles
F4 - Digitalis
Posts: 3
Joined: Mon Sep 05, 2016 1:40 am

Re: compile error

Post by JonNCGiles » Fri Sep 09, 2016 3:43 pm

Ducahamp and FFT:

Thanks so much for the help. I have figured out the problem and it was in my Giada conf file. In the conf file there are lines for sample directory and plugin directory. These for some reason were set to /dev, and after I set it to my home directory I could browse the files and load them. For some reason, with /dev as the directory I could not navigate onto the "real" fs. I don't think I set it like that on purpose, but once it was correct everything works, so far.

Thank you to everyone who has helped make this app, as it really is exactly what I need. I even donated a few bucks towards additional development.

jg

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: compile error

Post by FFT » Tue Oct 11, 2016 8:18 pm

Note: this no longer seems to be a problem with recent versions of JUCE.

motherB
F1 - Bilberry
Posts: 1
Joined: Sat Nov 19, 2016 11:57 am

Re: compile error

Post by motherB » Sat Nov 19, 2016 12:31 pm

Hey folks,

I really want to try out the recent version of this promising project but the ubuntu 64 deb doesn’t produce a working programme (no icon, just a name in programme list, nothing happening) in ubuntu studio 64 bit.

My version: Ubuntu Studio 16.04.1 LTS kernel 4.4.0-45-lowlatency

When configuring the recent 0.13.1 Source Code I get:

Code: Select all

~/Downloads/giada-0.13.1-src$  ./configure --target=linux --enable-vst 
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for g++... g++
checking whether we are using the GNU Objective C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking for pthread_exit in -lpthread... yes
checking how to run the C++ preprocessor... g++ -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking FL/Fl.H usability... yes
checking FL/Fl.H presence... yes
checking for FL/Fl.H... yes
checking RtMidi.h usability... yes
checking RtMidi.h presence... yes
checking for RtMidi.h... yes
checking jansson.h usability... yes
checking jansson.h presence... yes
checking for jansson.h... yes
checking sndfile.h usability... yes
checking sndfile.h presence... yes
checking for sndfile.h... yes
checking samplerate.h usability... yes
checking samplerate.h presence... yes
checking for samplerate.h... yes
checking X11/xpm.h usability... yes
checking X11/xpm.h presence... yes
checking for X11/xpm.h... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
However, when executing sudo su make install I get a cc1plus error

Code: Select all

g++ -DPACKAGE_NAME=\"giada\" -DPACKAGE_TARNAME=\"giada\" -DPACKAGE_VERSION=\"0.13\" -DPACKAGE_STRING=\"giada\ 0.13\" -DPACKAGE_BUGREPORT=\"giadaloopmachine@gmail.com\" -DPACKAGE_URL=\"\" -DPACKAGE=\"giada\" -DVERSION=\"0.13\" -DWITH_VST=1 -DHAVE_LIBPTHREAD=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -I.  -I./src/deps/juce -I./src/deps/vst -I/usr/include -I/usr/include/freetype2 -DJUCE_GLOBAL_MODULE_SETTINGS_INCLUDED=1 -DJUCE_STANDALONE_APPLICATION=1 -DJUCE_PLUGINHOST_VST=1 -DJUCE_PLUGINHOST_VST3=0 -DJUCE_PLUGINHOST_AU=0 -D__LINUX_ALSA__ -D__LINUX_PULSE__ -D__UNIX_JACK__   -std=c++11 -Wall -Werror -Wno-error=vla -Wno-error=misleading-indentation   -g -O2 -MT src/giada-main.o -MD -MP -MF src/.deps/giada-main.Tpo -c -o src/giada-main.o `test -f 'src/main.cpp' || echo './'`src/main.cpp
cc1plus: error: -Werror=misleading-indentation: no option -Wmisleading-indentation
Makefile:1551: recipe for target 'src/giada-main.o' failed
make: *** [src/giada-main.o] Error 1
I couldn’t find anything on this and, since I may not be the only one having problems, I am posting it. Ubuntu repos only have Giada 11 which is not quite sufficient to use all features.

I do have gcc and g++ in versions (Ubuntu 5.4.1-2ubuntu1~16.04) 5.4.1 20160904 each.

User avatar
FFT
F14 - Syrian Rue
Posts: 512
Joined: Thu Mar 08, 2012 6:51 pm

Re: compile error

Post by FFT » Sat Nov 19, 2016 5:42 pm

Hi motherB, you need to upgrade your GCC to GCC6 in order to build Giada. As for the "no icon" problem: what happens if you launch Giada from the command line with

Code: Select all

giada_lin
?

Post Reply