rtmidi-2.1.0 in giada-0.8.4 and adding rtaudio-4.1.1

Post Reply
Arty
F7 - Goldenseal
Posts: 13
Joined: Wed Dec 19, 2012 12:02 am

rtmidi-2.1.0 in giada-0.8.4 and adding rtaudio-4.1.1

Post by Arty » Fri May 23, 2014 5:49 pm

Not sure where to place this.

I'm using giada-0.8.4 and follow giada from git.
Latest changes in git is using rtmidi-2.1.0 but giada-0.8.4 still requires rtmidi-2.0.1

As there is only a minor API change (renaming RtError to RtMidiError) and
'Windows Kernel Streaming support was removed because it was uncompilable and incomplete' -
using the new release should be straight forward - here http://sprunge.us/CBKT?diff is a patch using rtmidi-2.1.0 in giada-0.8.4

I've also played with the new rtaudio-4.1.1 replacing embedded rtaudio in giada-0.8.4 and giada-git
This http://sprunge.us/ZLRh?diff patch adds jack support (__HACK__getJackClient()) - no version hack any more.

## prepare new rtaudio src
rm -fr rtaudio-4.1.1/{doc,autom4te.cache,contrib}
patch -p1 -i rtaudio-4.1.1.patch

## This is needed for (Arch) linux
(cd rtaudio-4.1.1; aclocal; autoconf)

## replace rtaudio
rm -fr giada-0.8.4-src/src/rtaudio
mv rtaudio-4.1.1 giada-0.8.4-src/src/rtaudio

## API name change
sed -i 's/RtError/RtAudioError/g' giada-0.8.4-src/src/kernelAudio.cpp

So far it works fine using alsa
I hope it helps someone, somehow.

http://www.music.mcgill.ca/~gary/rtmidi/
http://www.music.mcgill.ca/~gary/rtaudio/

User avatar
FFT
F14 - Syrian Rue
Posts: 518
Joined: Thu Mar 08, 2012 6:51 pm

Re: rtmidi-2.1.0 in giada-0.8.4 and adding rtaudio-4.1.1

Post by FFT » Sun May 25, 2014 5:12 pm

Great work Arty, we can finally get rid of the embedded RtAudio, among other things. We will update the docs very soon. Thanks for your help ;)

Post Reply